Important Note from Patriot Memory (Mar 15 2012)

Due to reported compatibility issues with firmware upgrade on AMD Platforms; we have removed firmware version 5.0.1 publically from our website. For those that have successfully flashed the firmware, rest assured that there are no issues and Patriot Memory will continue to offer support for these customers. For users that currently have version 3.3.2, we urge our users to continue to use this version if you are experiencing no major issues. As of now, version 3.3.2 will be deemed once again, our latest “official” release until these issues can be fixed. Our Engineers are currently working on the issue and hope to roll out either a fully compatible version of 5.0.1 or a newer version of 5.x.x that is also flash-compatible on both Intel and AMD Platforms.

We apologize for any inconvenience in the matter.

For access to firmware 5.0.1, please send an e-mail to support@patriotmem.com, and our support agents will be glad to send you a link for the firmware.

Thank You for choosing Patriot Memory.