Results 1 to 3 of 3

Thread: Problem with Transmission BT client / ipkg-cl

  1. #1

    Default Problem with Transmission BT client / ipkg-cl

    Hi guys, Im new to the forum, but ive been looking around on here for the last week or two for a way to fix the native BT client on my PBO. From my experience with it thus far, it seems like btpd is a rather poorly constructed program (which isnt surprising considering the PBO on the whole seems poorly constructed).

    Anyway, i read about and subsequently used snappy's "Transmission BT Client installation script" in order to sub btpd for Transmission instead. The first time i used Transmission it worked great, however after a while i started receiving an error message on the web interface stating that i had insufficient space on my HDD to continue downloading (i have a 500gb WD HDD installed with over 400gb free!). Hitting the refresh button next to each individual torrent seemed to get them going again, but it would become frustrating for me if i had to always do that just to keep them going, i mean it really defeats the purpose if the download process is no longer automated and continuous.

    Could someone please tell me what is happening and how i can fix it if possible?

    Im also having problems using ipkg-cl to install/remove optware. I would really, really like to remove btpd and unicgi from my PBO and following advice posted on this forum as to how to do that using ipkg-cl (eg, # ipkg-cl -recursive remove btpd), i always receive "-sh: ipkg-cl: not found" in the prompt.

    Is there something i have to do to "activate" ipkg-cl commands? Am i missing something here?

    Any help would be appreciated, cheers. PS, i am a total noob, please have mercy on my noob soul.

  2. #2
    Join Date
    Dec 2009
    Canada (ON)


    Whenever your torrent stops and complains that your disk space is insufficient; could you telnet to your PBO and enter the mount command to see if your HDD is still indicating that it is read-write (RW).

    It should look something like that: /dev/scsi/host0/bus0/target0/lun0/part1 on /tmp/hdd/volumes/HDD1 type ufsd (rw,nodiratime,uid=0,gid=0,fmask=0,dmask=0,sparse, force)

    Make sure it says rw vs ro on that line between ufsd and nodiratime. I had issues with my USB HDD becoming read-only ro for no apparent reasons in the past. Restarting the PBO would remount it as rw or simply using the mount command with the proper parameters.

    By the way although transmission works better than the native BT client it is far from ideal. Any bittorrent on this player is marginal at best; it just does not have the power to handle all the simultaneous network connections required by a torrent client. I build the script for transmission installation a long time ago and since have given up using the PBO for my torrent download.

    As for the removal of btpd; well since they were never really installed by ipkg-cl then they can not be removed by it. btpd is simply copied to the proper directory when you flash the firmware. I personally would not try to remove it unless you really know what you are doing; the boot up process look for that service "btpd" and if not found the whole process might just stop there in it's track leaving you with a brick PBO. The client is very small anyway; if you do not want it to run just kill the process by adding a line in your /usr/local/etc/rcS file. Something like:

    sleep 30
    killall btpd

    This should suffice to kill the process right after boot up.

    Cheers !!

  3. #3


    So, did the telnet. Disc is reading as rw so no problems there. I installed P70R2 megapack as i wanted to see for myself that ipkg would have no bearing on the ability to remove programs already installed on the system. As you would expect, i couldnt use ipkg to remove btpd or unicgi, fair enough.

    After conducting some more of my own research i have come to the same conclusion as you have snappy: the PBO is ill equiped to handle even the basic rigours of multiple peer connections. Transmission failed in its promise as a better alternative and using a remote program for Transmission on my Thinkpad Tablet instead of the web interface didnt fair any better. My solution (and thinking that led to it) is as follows:

    1. The very first thing i did was reflash my PBO to P53 BC16. My reasons for doing this were twofold:

    i. I have no need for any of the IMS functionality and seeing as its taylored more for the US, Asian and European markets (im Australian) it was no good to me anyway.

    ii. In my oppinion the old GUI looks a million times better than the new one and is more user friendly and less clumsy.

    2. After reflash, i thought that i would use my PC to download torrents, but set the download directory to one created on the PBO through my network and have files transfered to it wirelessly as they were simultaneously downloading from my PC. This would eliminate the need for the PBO to be able to manage multiple connections and just focus on one (from my PC). This would have worked fine if it werent for the large distances seperating my wireless router from both my PC and the PBO: it worked briefly, but soon after starting a torrent there would be a connection error and it would stop downloading, so no go there.

    3. My attention then focused on establishing a direct connection between the PBO and my Lenovo Thinkpad Tablet (which is located in the same room as the PBO). I was able to do this by enabling the hotspot function in Android, allowing the PBO to recognise it as a wireless AP. Unfortunately, i am unable to root this tablet, as a root method for it hasnt been developed yet, thus i would be unable to download torrents directly to the PBO through the tablet. In light of this, my new routine is to now download all movie torrents from the Thinkpad Tablet and then transfer them wirelessly via a direct link between the tablet and the PBO once they are complete. Transfer speeds range from 500kb/s to up to 700kb/s, which is fast enough to watch just about any video as its being transferred, so this is an acceptable soloution in my oppinion.

    Before i attempted any of this, i was seriously considering flashing the firmware on my D-Link DSL-2642B wireless router/modem with OpenWRT or DD-WRT and then installing transmission onto it, again to transfer torrents accross to the PBO as they were downloading at the same time. The problem for me with doing this is that this particular switch only has about 3mb of flash memory, so this would have been an impossible alternative. Despite this, i believe that the best way to have torrents passively downloading onto the PBO all the time without fail is to connect (via a very short ethernet hard link) a suitably OpenWRT/DD-WRT flashed switch with Transmission installed and then configure Transmission to transfer, as mentioned above, torrents whilst they are downloading at the same time.

    Anyway, a few things to ponder...

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts